глюк с кодировкой

Техническая сторона деятельности сайта и форумов.

Модераторы: El Lagarto, Never, sola, Slava, Марьяша

Ответить
serge
Сообщения: 37
Зарегистрирован: 12 апр 2006, 16:01

глюк с кодировкой

Сообщение serge » 15 апр 2007, 11:45

После вхождения на форум в качестве зарегистрированного пользователя оно начинает показывать все страницы в кодировке ISO 8859-1 (западноевропейская). Приходится вручную переключать на правильную CP-1251, но, к сожалению, при переходе на любую другую страницу форума все начинается сначала, то есть опять вылазит западноевропейская кодировка. Это относится как к просмотру тем/сообщений, так и к форме ответа. По-видимости (???), форум ориентируется на дефолтную кодировку браузера, и этот глюк проявляется прежде всего для тех, кто пишет из-за границы (как я сейчас). В любом случае считать по умоланию, что у всех пользователей браузер настроен на win-1251, и ПРИ ЭТОМ даже не предлагать (на стороне сервера) правильную кодировку - это какой-то дрэг. Например, в заголовке кода страницы стоит такое: <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">, хотя весь форум сработан в cp-1251. Эта нестыковка может НЕ проявиться только в одном случае: если клиент пользует канонические продукты микрософта включая интернет эксплорер. Для всех остальных (даже с фаерфоксом под виндовс) - "остается осадок"

serge
Сообщения: 37
Зарегистрирован: 12 апр 2006, 16:01

Re: глюк с кодировкой

Сообщение serge » 15 апр 2007, 11:58

serge писал(а):После вхождения на форум в качестве зарегистрированного пользователя оно начинает показывать все страницы в кодировке ISO 8859-1
Да, причина глюка заключается в выставлении языка по умолчанию при регистрации пользователя. Если указан язык интерфейса - английский, то оно почему-то везде лепит кодировку 8859-1. С какой такой радости совершенно никак не различаются язык ИНТЕРФЕЙСА и язык СООБЩЕНИЙ на форуме - это, наверное, к американским авторам. Но есть в этом что-то каловое.

Аватара пользователя
Slava
Администратор форума
Сообщения: 1233
Зарегистрирован: 04 фев 2005, 18:39
Откуда: Херсон
Контактная информация:

Re: глюк с кодировкой

Сообщение Slava » 15 апр 2007, 17:59

serge писал(а):В любом случае считать по умоланию, что у всех пользователей браузер настроен на win-1251, и ПРИ ЭТОМ даже не предлагать (на стороне сервера) правильную кодировку - это какой-то дрэг. Например, в заголовке кода страницы стоит такое: <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">, хотя весь форум сработан в cp-1251. Эта нестыковка может НЕ проявиться только в одном случае: если клиент пользует канонические продукты микрософта включая интернет эксплорер.
Правильно говоришь, только есть одно большое но. Если делать всё по правилам и стандартам, подобные сообщения начнут появляться здесь чуть ли не ежедневно. И в них пользователи будут требовать принудительно прописать кодировку win-1251 в заголовке. Уж поверь, у меня есть в этом опыт с практикой. А пока большинство пользователей довольно текущим положением дел, то и менять скорее всего ничего не придется. Я к тому, что в вопросе кодировок всем сразу не угодишь, как и в любом другом вопросе тоже.
serge писал(а):Да, причина глюка заключается в выставлении языка по умолчанию при регистрации пользователя. Если указан язык интерфейса - английский, то оно почему-то везде лепит кодировку 8859-1. С какой такой радости совершенно никак не различаются язык ИНТЕРФЕЙСА и язык СООБЩЕНИЙ на форуме - это, наверное, к американским авторам. Но есть в этом что-то каловое.
Наверняка у американских авторов уже заготовлен какой-то ответ на этот вопрос - посмотри на phpbb.com, если с английским дружишь. Может, что-то полезное узнаем и как-то исправим такую недоработку.
Там, где небо сойдется с Землёй,
Там, где звезды увидят закат,
Там, где вечность умыта росой,
Где растет золотой виноград,
Будем мы!

Ответить

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 1 гость